X   Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Проблемы с установкой Eleanor CMS
Гость_UserPatrone_*
сообщение 2009-12-08, 22:17
Сообщение #1



Гости





Вроде бы не дурак и делаю всё правильно, в чём может быть проблема? Заливают всё на хост и выдаёт такое вот дело на главной странице Parse error: syntax error, unexpected '{' in /home/progamer/public_html/index.php on line 33  Если обратиться на страницу установки такое: Parse error: syntax error, unexpected '&', expecting T_VARIABLE or '$' in /home/progamer/public_html/install/install.php on line 281

Кто может подсказать в чём проблема? С хостингом связывался, всё как в требованиях написано соблюдено. Очень интересен этот движок, хочу завести на нём проект об играх, но не заводится.
Перейти в начало страницы
+Цитировать сообщение
Zorazo
сообщение 2009-12-08, 22:19
Сообщение #2
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 207
Регистрация: 2009-06-28
Из: Краснодар

Репутация: нет


php какая версия???
Перейти в начало страницы
+Цитировать сообщение
NoIndex
сообщение 2009-12-08, 22:22
Сообщение #3
Опытный
Иконка группы

Группа: Бета-тестеры
Сообщений: 825
Регистрация: 2008-12-13
Из: Россия → Новосибирск
Версия системы: RC5

Репутация: 24


Цитата (UserPatrone @ 9.12.2009, 1:17)
сё как в требованиях написано соблюдено.

http://forum.eleanor-cms.ru/index.php?show...post&p=6884
Перейти в начало страницы
+Цитировать сообщение
Гость_UserPatrone_*
сообщение 2009-12-08, 22:24
Сообщение #4



Гости





Версия PHP 4.4.9
Версия Apache    2.2.14
Версия MySQL    5.0.85
Перейти в начало страницы
+Цитировать сообщение
NoIndex
сообщение 2009-12-08, 22:27
Сообщение #5
Опытный
Иконка группы

Группа: Бета-тестеры
Сообщений: 825
Регистрация: 2008-12-13
Из: Россия → Новосибирск
Версия системы: RC5

Репутация: 24


Цитата (UserPatrone @ 9.12.2009, 1:24)
Версия PHP 4.4.9

Минимальная версия PHP: 5.2.6.
http://forum.eleanor-cms.ru/index.php?show...&#entry9014

Сообщение отредактировал NoIndex - 2009-12-08, 22:31
Перейти в начало страницы
+Цитировать сообщение
Гость_UserPatrone_*
сообщение 2009-12-08, 22:31
Сообщение #6



Гости





В противном случае, как я понял не поставить CMS ? Если так, то может посоветуете, что-то гибкое и универсальное для поднятия сайта и публикации на нём обзоров и новостей? Уж путаюсь, что бы мне можно поставить. C WordPress есть опыт работы, но шаблон в любом случае надо заказывать, да и к тому же он больше блоговый. А Drupal не нравится мне в принципе.
Перейти в начало страницы
+Цитировать сообщение
Zorazo
сообщение 2009-12-08, 22:32
Сообщение #7
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 207
Регистрация: 2009-06-28
Из: Краснодар

Репутация: нет


UserPatrone, если у тебя cpanel то есть шанс что включено и php5

Сообщение отредактировал Zorazo - 2009-12-08, 22:34
Перейти в начало страницы
+Цитировать сообщение
NoIndex
сообщение 2009-12-08, 22:33
Сообщение #8
Опытный
Иконка группы

Группа: Бета-тестеры
Сообщений: 825
Регистрация: 2008-12-13
Из: Россия → Новосибирск
Версия системы: RC5

Репутация: 24


Цитата (UserPatrone @ 9.12.2009, 1:31)
В противном случае, как я понял не поставить CMS ?

Ставить, но сменить хостера.
Цитата (UserPatrone @ 9.12.2009, 1:31)
Если так, то может посоветуете

Вам, пожалуй тогда сюда.
Цитата (Zorazo @ 9.12.2009, 1:32)
если у тебя cpanel то есть возможность что включено и php5

Бред. Всё зависит от хостера, если он предоставляет смену PHP, то такая возможность естественно есть, но такое есть далеко не всегда и не везде.

Сообщение отредактировал NoIndex - 2009-12-08, 22:37
Перейти в начало страницы
+Цитировать сообщение
Zorazo
сообщение 2009-12-08, 22:37
Сообщение #9
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 207
Регистрация: 2009-06-28
Из: Краснодар

Репутация: нет


NoIndex, ну допустим у меня была та же самая проблема, пока меня хостер носом не торкнул, где менять версию php
Перейти в начало страницы
+Цитировать сообщение
Гость_UserPatrone_*
сообщение 2009-12-08, 22:56
Сообщение #10



Гости





То есть данная проблема возникла исключительно из-за старой версии PHP сервера? И пожалуй ещё возникает резонный вопрос, данный CMS полностью бесплатен?
Перейти в начало страницы
+Цитировать сообщение
Screatch
сообщение 2009-12-08, 23:34
Сообщение #11
Опытный
Иконка группы

Группа: Eleanor TEAM
Сообщений: 717
Регистрация: 2008-11-11
Из: Таллинн

Репутация: 20


Да, потыкайте хостера палочкой, может обновит, если нет, уходите от туда.
И да CMS бесплатна, платны будут только некоторые модули.
Перейти в начало страницы
+Цитировать сообщение
Гость_UserPatrone_*
сообщение 2009-12-09, 11:07
Сообщение #12



Гости





Всё встало, большое спасибо. Решили всё с хостером, он поковырялся у себя, а я прописал строку в файл .htaccess
AddHandler application/x-httpd-php5 .php
Хотелось бы узнать, а как можно купить доступ к дополнительным модулям данной CMS или как-то происходит в особом порядке?
Перейти в начало страницы
+Цитировать сообщение
Screatch
сообщение 2009-12-09, 11:17
Сообщение #13
Опытный
Иконка группы

Группа: Eleanor TEAM
Сообщений: 717
Регистрация: 2008-11-11
Из: Таллинн

Репутация: 20


Модули будут покупаться по штучно или сборками, централизованный магазин модулей появиться чуть позже, пока есть где-то тема на форуме.
Перейти в начало страницы
+Цитировать сообщение
azacgrus
сообщение 2009-12-09, 15:48
Сообщение #14
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 246
Регистрация: 2008-12-13
Из: Санкт-Петербург

Репутация: 12


UserPatrone, сейчас доступ к файловому архиву открывается только после регистрации своего сайта в каталоге. http://eleanor-cms.ru/cabinet.html активация проходит в автоматичепском режиме.
Перейти в начало страницы
+Цитировать сообщение

Ответить в данную темуНачать новую тему
0 чел. читают эту тему (гостей: 0, скрытых пользователей: 0)
Пользователей: 0

 
RSS Текстовая версия 0.0493 сек.    11 запросов    GZIP включен    Сейчас: 2021-09-21, 10:46