X   Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Ошибка при входе в админку
Гость_mustafa1453_*
сообщение 2010-02-06, 21:11
Сообщение #1



Гости





Установил елеанор на локальный веб-сервер(Apache2.0+php5.2.9+MySQL 5.1.39). Все установилось хорошо. Но при входе в админку выдает
<code>При выполнении запроса произошла ошибка: <b>(error #1064) You have   an error in your SQL syntax; check the manual that corresponds to your   MySQL server version for the right syntax to use near &#039;)&#039; at line 1</b>
 
 Адрес   ошибки: <b>C:Program FilesApache   GroupApache2htdocstestaddonsadminkamoduleslcomments.php[232].</b></code>

Вот файл-лог ошибок:
 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near &#039;)&#039; at line 1
  Query: SELECT COUNT(`id`) FROM `el_comments` WHERE `mid` IN ()
  Line: 232 in file C:Program FilesApache GroupApache2htdocstestaddonsadminkamoduleslcomments.php
  URL: /test/admin.php
  Date: 2010-02-06 18:55:17
  IP: 127.0.0.1
Перейти в начало страницы
+Цитировать сообщение
sanes
сообщение 2010-02-06, 21:45
Сообщение #2
Аноним
Иконка группы

Группа: Пользователи
Сообщений: 1 180
Регистрация: 2008-12-29
Из: Волгоград

Репутация:   нет  
Всего: 4


я так понял установили, чтобы посмотреть? ну поставьте вы на сервер, на котором работает. на винде - это Denwer, Vertrigo..
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2010-02-07, 14:10
Сообщение #3
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


mustafa1453, при установке все таблицы и знаничения, записываемые в них, должны быть зелеными. У Вас, наверное, они были красными? Проверьте...
Перейти в начало страницы
+Цитировать сообщение
Гость_mustafa1453_*
сообщение 2010-02-07, 18:35
Сообщение #4



Гости





Alexander, я пользовался лично собраным веб-сервером, без phpMyAdmin.
А так поставил денвер, и на него елеанор. Все прекрасно. Спасибо за подсказку.
Перейти в начало страницы
+Цитировать сообщение
Гость_AntonMMА_*
сообщение 2010-08-03, 9:33
Сообщение #5



Гости





Такая же бодяга. При установке modules было подсвечено красным цветом, в админку войти нельзя, ошибка:
Цитата
При выполнении запроса произошла ошибка: (error #1064) You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

Адрес ошибки: G:\www\iais.kuzstu\www\addons\adminka\modules\lcomments.php[239].

При открытии файла lcomments.php на 239 строке запись:
Цитата
$Mainclass->Db->Query('SELECT COUNT(`id`) FROM `f_comments`'.$where,__file__,__line__);

И таблицы f_comments (равно как и el_f_comments) не существует в БД.

На локальной машине Apache 2.2.15 + PHP 5.3.2 + MySQL 5.1

Я так понимаю, что почему-то при установке не удаётся выполнить запись в файлы папки addons\adminka\modules

Сообщение отредактировал AntonMMА - 2010-08-03, 10:29
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2010-08-03, 17:11
Сообщение #6
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


AntonMMА, там должно быть написано так:

$Mainclass->Db->Query('SELECT COUNT(`id`) FROM `f_comments`'.$where,__file__,__line__);
Перейти в начало страницы
+Цитировать сообщение
Гость_sabriil_*
сообщение 2011-02-24, 12:50
Сообщение #7



Гости





Здравствуте. Ставлю на локалхост таже самая ошибка и при установке надпись modules было красным.
помогите решить проблему.
Установка денвера и тд не вариант. мне нужно разобраться именно что у меня не так или в инсталяторе.
Перейти в начало страницы
+Цитировать сообщение
Гость_sabriil_*
сообщение 2011-02-24, 13:46
Сообщение #8



Гости





Цитата (sabriil @ 2011-02-24, 12:50)
Здравствуте. Ставлю на локалхост таже самая ошибка и при установке надпись modules было красным.
помогите решить проблему.
Установка денвера и тд не вариант. мне нужно разобраться именно что у меня не так или в инсталяторе.


выявил что рукается на

	$insert['modules']="INSERT INTO `{$prefix}modules` VALUES
		(NULL, ',1,3,6,2,', 'news', 'Новости', 'Управление новостями Вашего сайта', 0, 'modules/news', 1, 'index.php', '', '', 'news-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,2,', 'page', 'Статические страницы', 'Модуль для создания статических страниц.', 1, 'modules/static', 1, 'index.php', '', '', 'static-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,2,', 'mainpage', 'Главная страница', 'Конструктор главной страницы сайта', 1, 'modules/mainpage', 1, 'index.php', '', '', 'mainpage-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,2,', 'errors', 'Страницы ошибок', 'Настройка страниц ошибок Вашего сайта (404,403..)', 1, 'modules/errors', 1, 'index.php', '', '', 'errors-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,2,', 'contacts', 'Контакты', 'Обратная связь', 0, 'modules/contacts', 1, 'index.php', '', '', 'contacts-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,3,6,2,', 'faq', 'Вопросы и ответы', 'Создание FAQ', 0, 'modules/faq', 1, 'index.php', '', '', 'faq-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',2,', 'search', 'Поиск', '', 0, 'modules/search', 0, 'index.php', '', '', '', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,2,', 'menu', 'Меню сайта', 'Управление меню', 0, 'modules/menu', 1, 'index.php', '', '', 'menu-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,3,2,', 'account', 'Аккаунт пользователя', 'Страница настройки аккаунта пользователя', 0, 'modules/account', 1, 'index.php', '', '', 'account-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,3,6,2,', 'files', 'Файлы', 'Управление файловым архивом проекта', 0, 'modules/files', 1, 'index.php', '', '', 'files-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,3,2,', 'voting', 'Опросы', 'Управление опросами на сайте', 0, 'modules/voting', 1, 'index.php', '', '', 'voting-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,3,6,2,', 'blogs', 'Блоги', 'Управление блогами на сайте', 0, 'modules/blogs', 1, 'index.php', '', '', 'blogs-%.png', 1, '', '', 0, 0, -1, 'plugins.php')";

на 10 позиции должно стоять значение типа интегер. а стоит '' поэтому таблица modules получается пустой.
как быть?
Перейти в начало страницы
+Цитировать сообщение
Гость_sabriil_*
сообщение 2011-02-24, 14:03
Сообщение #9



Гости





Подправил. вроде работает.

	$insert['modules']="INSERT INTO `{$prefix}modules` VALUES
		(NULL, ',1,3,6,2,', 'news', 'Новости', 'Управление новостями Вашего сайта', 0, 'modules/news', 1, 'index.php', 0, '', 'news-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,2,', 'page', 'Статические страницы', 'Модуль для создания статических страниц.', 1, 'modules/static', 1, 'index.php', 0, '', 'static-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,2,', 'mainpage', 'Главная страница', 'Конструктор главной страницы сайта', 1, 'modules/mainpage', 1, 'index.php', 0, '', 'mainpage-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,2,', 'errors', 'Страницы ошибок', 'Настройка страниц ошибок Вашего сайта (404,403..)', 1, 'modules/errors', 1, 'index.php', 0, '', 'errors-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,2,', 'contacts', 'Контакты', 'Обратная связь', 0, 'modules/contacts', 1, 'index.php', 0, '', 'contacts-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,3,6,2,', 'faq', 'Вопросы и ответы', 'Создание FAQ', 0, 'modules/faq', 1, 'index.php', 0, '', 'faq-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',2,', 'search', 'Поиск', '', 0, 'modules/search', 0, 'index.php', 0, '', '', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,2,', 'menu', 'Меню сайта', 'Управление меню', 0, 'modules/menu', 1, 'index.php', 0, '', 'menu-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,3,2,', 'account', 'Аккаунт пользователя', 'Страница настройки аккаунта пользователя', 0, 'modules/account', 1, 'index.php', 0, '', 'account-%.png', 1, '', '', 0, 0, -1, ''),
		(NULL, ',1,3,6,2,', 'files', 'Файлы', 'Управление файловым архивом проекта', 0, 'modules/files', 1, 'index.php', 0, '', 'files-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,3,2,', 'voting', 'Опросы', 'Управление опросами на сайте', 0, 'modules/voting', 1, 'index.php', 0, '', 'voting-%.png', 1, '', '', 0, 0, -1, 'plugins.php'),
		(NULL, ',1,3,6,2,', 'blogs', 'Блоги', 'Управление блогами на сайте', 0, 'modules/blogs', 1, 'index.php', 0, '', 'blogs-%.png', 1, '', '', 0, 0, -1, 'plugins.php')";


Почему так? Мускл как то сам должен был реагировать на ошибку? подскажите пожалуйста
Перейти в начало страницы
+Цитировать сообщение

Ответить в данную темуНачать новую тему
0 чел. читают эту тему (гостей: 0, скрытых пользователей: 0)
Пользователей: 0

 
RSS Текстовая версия 0.0449 сек.    11 запросов    GZIP включен    Сейчас: 2020-10-27, 6:28