X   Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Нет переадресации после регистрации, RC5
Гость_reclearerr_*
сообщение 2011-09-21, 21:29
Сообщение #1



Гости





Доброго вечера всем. Вчера столкнулся с проблемой. После нажатия кнопки "Зарегестрироваться!" не выполняется переадресация на страницу завершения регистрации (белый лист), с восстановлением пароля - та же проблема. Залез в modules\account\user\index.php. Как я понял - проблема в том, что функция AcActivate() не вызывается, но возможно я не прав, скорее даже точно не прав, ибо php не изучал, да и не особо хочется.

Используется VertrigoServ (Apache 2.2.17, PHP 5.3.6, MySQL 5.5.10)
Перейти в начало страницы
+Цитировать сообщение
KDesign
сообщение 2011-09-21, 21:39
Сообщение #2
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 153
Регистрация: 2009-09-18
Из: Екатеринбург

Репутация:   нет  
Всего: нет


У меня такой же баг,используй альфу лучше
Перейти в начало страницы
+Цитировать сообщение
Гость_reclearerr_*
сообщение 2011-09-21, 21:45
Сообщение #3



Гости





Хотелось бы разбораться таки в проблеме, да и альфа еще не до конца реализована, если не ошибаюсь.
В коде ошибок вроде нет, да и у других такой проблемы не замечал. Может проблема в настройке PHP, ибо ну почему еще интерпретатор не хочет генерить html-файлик
Перейти в начало страницы
+Цитировать сообщение
KDesign
сообщение 2011-09-21, 21:48
Сообщение #4
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 153
Регистрация: 2009-09-18
Из: Екатеринбург

Репутация:   нет  
Всего: нет


да, скорее всего какой то модуль в php выключен
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2011-09-22, 0:11
Сообщение #5
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


reclearerr, при определенном POST запросе (при клике "Ок" в форме), браузер не переходит на новую страницу? Я правильно понимаю?
На какую страницу он переходит? В логах есть какие-то ошибки?
Перейти в начало страницы
+Цитировать сообщение
Гость_reclearerr_*
сообщение 2011-09-22, 5:49
Сообщение #6



Гости





Alexander, при нажатии кнопки "Зарегестрироваться", если все поля введены правильно, пользователь добавляется в базу данных, но не открывается сообщение об успешной регистрации. То бишь нажал "Ок" - появилась пустая страница. Полазил по логам, понял, что письмо по мылу не отправляется, ибо:

Warning: mail() [<a href='function.mail'>function.mail</a>]: Failed to connect to mailserver at &quot;localhost&quot; port 25, verify your &quot;SMTP&quot; and &quot;smtp_port&quot; setting in php.ini or use ini_set() Line: 193 in file C:\Program Files\VertrigoServ\www\classes\others\class_email.php
 URL: /account/do_register.html
 Date: 2011-09-20 19:20:03
 IP: 127.0.0.1


и

Произошла ошибка отправки! Line: 194 in file C:\Program Files\VertrigoServ\www\classes\others\class_email.php
 URL: /account/do_register.html
 Date: 2011-09-20 19:20:03
 IP: 127.0.0.1



Сообщение отредактировал reclearerr - 2011-09-22, 5:50
Перейти в начало страницы
+Цитировать сообщение
KDesign
сообщение 2011-09-22, 7:18
Сообщение #7
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 153
Регистрация: 2009-09-18
Из: Екатеринбург

Репутация:   нет  
Всего: нет


хм...полезная информация спасибо!
не думал что даже мыло не отправляется
Перейти в начало страницы
+Цитировать сообщение
Гость_reclearerr_*
сообщение 2011-09-22, 13:27
Сообщение #8



Гости





SMTP-сервер включен, отправляться все должно. Странно же.
Перейти в начало страницы
+Цитировать сообщение
Гость_reclearerr_*
сообщение 2011-09-22, 21:17
Сообщение #9



Гости





Alexander, не подскажете тогда уж, что и где вписать, дабы редиректнуло на главную и уже залогиненого? Заранее благодарен.
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2011-09-24, 0:03
Сообщение #10
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


Цитата (reclearerr @ 2021-01-28 19:44)
SMTP-сервер включен, отправляться все должно. Странно же.

А у вас отправка включена через SMTP (в админке). Судя по ошибке, у Вас именно через PHP mail.
Перейти в начало страницы
+Цитировать сообщение
Гость_reclearerr_*
сообщение 2011-10-07, 18:48
Сообщение #11



Гости





Можно ли в RC5 вообще отключить Mailer, дабы SMTP даже не пытался отправить сообщение на мыло? Полазил в настройках, обнаружил только выбор между php mail() и SMTP
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2011-10-08, 0:51
Сообщение #12
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


Закомментируйте всё содержимое функции Send в файле classes/others/class_email.php
Перейти в начало страницы
+Цитировать сообщение

Ответить в данную темуНачать новую тему
0 чел. читают эту тему (гостей: 0, скрытых пользователей: 0)
Пользователей: 0

 
RSS Текстовая версия 0.0454 сек.    11 запросов    GZIP включен    Сейчас: 2021-01-28, 18:44