X   Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Отказ от поддержки PHP 5.2.x
Alexander
сообщение 2012-06-21, 4:24
Сообщение #1
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


Все чаще посещает мысль отказаться уже от поддержки PHP 5.2.x и перейти на PHP 5.3.x а лучше на PHP 5.4 (чтобы трейты юзать). Тогда можно будет еще более улучшить код, подогнав его под большинство рекомендаций принципов SOLID. + появится возможность вынести большинство кода в Eleanor Framework для того, чтобы и другие могли писать свои CMSки ;)
Перейти в начало страницы
+Цитировать сообщение
Djadka
сообщение 2012-06-21, 8:08
Сообщение #2
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 463
Регистрация: 2010-10-17

Репутация:   нет  
Всего: нет


до 5.4 надо ждать хотя бы месяцев 6-8. А то нормальные хостинг провайдеры ставят к себе новую версию пхп только с нормальным обкатом.(писал уже =) )
Перейти в начало страницы
+Цитировать сообщение
DeD
сообщение 2012-06-21, 9:38
Сообщение #3
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 153
Регистрация: 2009-03-01
Из: Россия, Краснодар

Репутация:   нет  
Всего: нет


Alexander, использование новых возможностей php и подгонка под рекомендации это конечно хорошо, но все же я думаю не стоит торопиться. Решать тебе все же. Сначала лучше выпустить финал, а уж затем думать об этом.
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2012-06-21, 15:16
Сообщение #4
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


DeD, и снова все тупо ждут финал... мда.
Djadka, где-то к этому времени и появится версия, так что думаю, если сейчас ориентироваться на 5.4 то как только 5.4 будет стоять везде - так сразу и версия новая выйдет :)
Перейти в начало страницы
+Цитировать сообщение
Loader
сообщение 2012-06-21, 18:28
Сообщение #5
Профессионал
Иконка группы

Группа: Eleanor user
Сообщений: 1 161
Регистрация: 2010-04-19

Репутация:   нет  
Всего: нет


Цитата (Alexander @ 2021-08-06 01:09)
DeD, и снова все тупо ждут финал... мда.

Почему? Я его совсем не жду! Мне и так хорошо. :sarcastic_hand:
Перейти в начало страницы
+Цитировать сообщение
LuxCore
сообщение 2012-06-21, 20:04
Сообщение #6
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 278
Регистрация: 2011-11-09

Репутация:   нет  
Всего: нет


А мне греет душу само существование системы Eleanor. Я и так вижу, что проект не стоит на месте, да и сам Александр говорит, в какую сторону собирается развивать своё детище.
Перейти в начало страницы
+Цитировать сообщение
Djadka
сообщение 2012-06-21, 20:57
Сообщение #7
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 463
Регистрация: 2010-10-17

Репутация:   нет  
Всего: нет


Вот почему то вот как то вот кажеться что пока не стоит. Я бы полностью сейчас первёл бы её на 5.3 и сделал бы отдельную ветку под 5.4. Потому что надо добиться универсализма.
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2012-06-23, 19:56
Сообщение #8
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


Djadka, думаю, месяцев через 5 везде будет стоять 5.4 . До этого первая версия точно не выйдет - так что по-моему уже сейчас есть смысл переходить на 5.4...
Перейти в начало страницы
+Цитировать сообщение
termit
сообщение 2012-06-24, 16:08
Сообщение #9
Опытный
Иконка группы

Группа: Бета-тестеры
Сообщений: 705
Регистрация: 2009-06-02
Из: Житомир

Репутация:   нет  
Всего: 11


Немного оффтопа и юмора.
Решил поработать с одним фреймворком (F3).
Сделал небольшой проэкт, залил на хост. - Не работает. (на хосту php5.2 нужен php5.3+).
Меняю на php 5.3 - не работает, но ощибка уже другая
Меняю на php 5.4 - имею internal server error (даже на скрипте в котором и есть только что <?php phpinfo();?>)
Пишу в тех поддержку

Я
Цитата
Здраствуйте.
Насколько я понял php5.4 работает в режиме cgi. Можно ли както его использовать как модуль апача.
Не работают даже елементарные скрипты. например phpinfo http://*/phpinfo.php


Ответ мне понравился)

Вася П.
Цитата
Добрый день. На данный момент php5.4 - не стабильная версия, рекомендуем использовать php5.3


Я
Цитата
Извиняюсь, но не настолько ведь не стабильная что не может сделать даже <?php phpinfo();?>
Вопрос немного не о том.

Андрей Г.
Цитата
может. только нужно было отключить magic_quotes_gpc. Просто как модуль апача использовать нельзя


Перейти в начало страницы
+Цитировать сообщение
Djadka
сообщение 2012-06-24, 16:17
Сообщение #10
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 463
Регистрация: 2010-10-17

Репутация:   нет  
Всего: нет


Цитата (Alexander @ 2012-06-23, 20:56)
Djadka, думаю, месяцев через 5 везде будет стоять 5.4 . До этого первая версия точно не выйдет - так что по-моему уже сейчас есть смысл переходить на 5.4...


Да только мой хостер тупит на эту тему.
Перейти в начало страницы
+Цитировать сообщение
Phoenix84
сообщение 2012-06-24, 16:43
Сообщение #11
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 231
Регистрация: 2010-03-31
Версия системы: RC5

Репутация:   нет  
Всего: нет


Alexander, толковой документации к php 5.4 сейчас практически не найти. Да и 5.3 будет существовать столько же сколько и php 5.2
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2012-06-25, 2:48
Сообщение #12
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


Цитата (Phoenix84 @ 2021-08-06 01:09)
Alexander, толковой документации к php 5.4 сейчас практически не найти.

А какую документацию вы ждете? :) Был обзор новинок, уже понятно как ими пользоваться. Чего не хватает?

PHP 5.4 вполне стабильно, если суди по http://php.net/downloads.php
Перейти в начало страницы
+Цитировать сообщение

Ответить в данную темуНачать новую тему
0 чел. читают эту тему (гостей: 0, скрытых пользователей: 0)
Пользователей: 0

 
RSS Текстовая версия 0.0501 сек.    11 запросов    GZIP включен    Сейчас: 2021-08-06, 0:09