X   Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Установка на Openserver, При запуске install.php выскакивает ошибка
Гость_4erepaha_*
сообщение 2013-01-28, 13:59
Сообщение #1



Гости





Добрый день.

Пытаюсь установить eleanor_cms_0.9 на Openserver и при обращении к http://site1.ru/install/install.php выскакивает ошибка:

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in E:\OpenServer\domains\site1.ru\core\core.php on line 1265

строка 1265 представляет собой: if(!$over=$L::GetUserValue($go) or !isset($over['method'][$p],$over['value'][$p]) or $over['method'][$p]=='inherit') вот в таком сочетании:

public static function GetPermission($p,$L=false,$t=false,$go='groups_overload')
    {
        if(!$L)
            $L=self::$Login;
        if(!$over=$L::GetUserValue($go) or !isset($over['method'][$p],$over['value'][$p]) or $over['method'][$p]=='inherit')
            return self::Permissions(self::GetUserGroups($L),$p,$t);
        $res=($add=$over['method'][$p]=='replace') ? array($over['value'][$p]) : self::Permissions(self::GetUserGroups($L),$p,$t);
        if(!$add)
            $res[]=$over['value'][$p];
        return$res;
    }

Подскажите кого где добавить/удалить/закоментировать чтоб это всё заработало.
Перейти в начало страницы
+Цитировать сообщение
wormen
сообщение 2013-01-28, 14:23
Сообщение #2
Опытный
Иконка группы

Группа: Eleanor user
Сообщений: 800
Регистрация: 2012-09-13

Репутация:   нет  
Всего: нет


какая версия сервера?
Перейти в начало страницы
+Цитировать сообщение
Гость_4erepaha_*
сообщение 2013-01-28, 14:29
Сообщение #3



Гости





версия продукта 4.7.6.0
Перейти в начало страницы
+Цитировать сообщение
wormen
сообщение 2013-01-28, 14:34
Сообщение #4
Опытный
Иконка группы

Группа: Eleanor user
Сообщений: 800
Регистрация: 2012-09-13

Репутация:   нет  
Всего: нет


работаю на этом же сервере той же версии, никаких проблем.....
попробуйте скачать отсюда последнюю версию CMS

Сообщение отредактировал wormen - 2013-01-28, 14:34
Перейти в начало страницы
+Цитировать сообщение
Гость_4erepaha_*
сообщение 2013-01-28, 15:30
Сообщение #5



Гости





не хотит работать всё равно ((((( я уже и ютф8 попробывал поставить - ни в какую (((

может это из-за системы чего? стоит Win 7 x32 - може в ней дело?
Перейти в начало страницы
+Цитировать сообщение
Hoodlum
сообщение 2013-01-28, 19:21
Сообщение #6
Любитель
Иконка группы

Группа: Eleanor user
Сообщений: 113
Регистрация: 2011-12-20

Репутация:   нет  
Всего: нет


Цитата (4erepaha @ 2013-01-28, 15:30)
не хотит работать всё равно ((((( я уже и ютф8 попробывал поставить - ни в какую (((

может это из-за системы чего? стоит Win 7 x32 - може в ней дело?

Нет дело и не win 7, у меня стоит версия 4.6.0 на Win 7 x32 и все отлично работает. Дело может быть у вас в том что не настроен домен, я смотрю установка происходит site1.ru, попробуй домен обычный localhost?
Перейти в начало страницы
+Цитировать сообщение
Гость_4erepaha_*
сообщение 2013-01-28, 22:27
Сообщение #7



Гости





сё. вопрос снят. черепашка немного медленная, потому не получалось )))

проблема была в версии PHP. я посмотрел что на сервере есть 3 штуки и решил что по умолчанию стоит последняя ))) а оказалось - первая.

Сообщение отредактировал 4erepaha - 2013-01-28, 22:30
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2013-01-29, 0:01
Сообщение #8
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


4erepaha, все правильно :) Eleanor CMS 0.9 требует PHP не ниже 5.3 версии.
Перейти в начало страницы
+Цитировать сообщение

Ответить в данную темуНачать новую тему
0 чел. читают эту тему (гостей: 0, скрытых пользователей: 0)
Пользователей: 0

 
RSS Текстовая версия 0.0453 сек.    11 запросов    GZIP включен    Сейчас: 2021-11-30, 8:41