X   Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

 
Тема закрытаНачать новую тему
> Проблеми с Редактором шаблонов
Гость_Aleksander_*
сообщение 2009-06-02, 23:18
Сообщение #1



Гости





При попытке зайти в модуль Редактор шаблонов появляется ошибка
Warning: Unexpected character in input: ' in /home/nasharu/data/www/xost/addons/adminka/modules/themes_editor/index.php on line 86

Parse error: syntax error, unexpected ')' in /home/nasharu/data/www/xost/addons/adminka/modules/themes_editor/index.php on line 86
Подскажите из-за чего это может быть и как исправить.
Перейти в начало страницы
+Цитировать сообщение
Alexander
сообщение 2009-06-03, 0:25
Сообщение #2
Eleanor developer
Иконка группы

Группа: Администраторы
Сообщений: 5 261
Регистрация: 2008-11-11
Из: Николаев
Версия системы: RC5

Репутация:   нет  
Всего: 67


Aleksander, странно как-то. В системе нигде нет PARSE ERROR-ов. На всякий случай привожу строки из файла addons/adminka/modules/themes_editor/index.php 80-89:
		if (empty($service) or !is_array($service))
			$services=$Mainclass->lang['th_edit']['all'];
		else
		{
			$services=array();
			foreach($service as $v)
				if (isset($Mainclass->services[$v]))
					$services[]=$Mainclass->services[$v]['name'];
			$services=empty($services) ? $Mainclass->lang['main']['no'] : join(', ',$services);
		}

Если у Вас они отличаются, значит попробуйте перекачать архив и по-новой инсталлировать систему (я только что с удивлением обнаружил, что архив системы на сервере битый почему-то :( ). О проделанном расскажите.
Перейти в начало страницы
+Цитировать сообщение
Гость_Aleksander_*
сообщение 2009-06-03, 17:59
Сообщение #3



Гости





Ошибка пропала после того как скачал с сайта и переустановил cms.
Перейти в начало страницы
+Цитировать сообщение

Тема закрытаНачать новую тему
0 чел. читают эту тему (гостей: 0, скрытых пользователей: 0)
Пользователей: 0

 
RSS Текстовая версия 0.0395 сек.    11 запросов    GZIP включен    Сейчас: 2020-05-29, 10:24