CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Обсуждение RC5
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Первые шаги
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51
sanes
Diego, попробуй воспроизвести мой косяк..
Alexander
Цитата (Loader @ 2021-07-29 00:14)
Дело в том, что кириллические ссылки я давно отключил

Как отключили? Отключение обратной силы не имеет....

Цитата (sanes @ 2021-07-29 00:14)
http://ht-lab.ru тоже позавчерашняя версия, время хз. Рейтинг вроде ОК! При удалении .html в настройках новостей, не открывается полная новость (404) и не отображается рейнинг в краткой новости.

У ссылок должно быть окончание, иначе возникает неоднозначность. Например: news/что-то/кто-то/где-то - это категория или новость? Хотя имея небольшие навыки программирования - можно заточить распознавание ссылок под себя.
Loader
Цитата (Alexander @ 2010-07-20, 21:46)
Как отключили? Отключение обратной силы не имеет....

Alexander, описываю подробнее:
Сначала у меня эта галка не стояла:

И некоторое количество новостей было добавлено без неё.В дальнейшем я эту галку поставил.После этого я все новости перередактировал с той целью, чтобы URL-ы все были транслитом.Но по какой-то причине даже после этого часть ссылок в sitemap-е генерируется в старом варианте, русскими буквами.Приведу примеры:



-это из файла sitemap.Теперь смотрим эти новости на сайте:


и так далее, на сайте они давно на английском, а в сайтмапе генерируется русская ссылка!!!
Почему? :o
Loader
Alexander, и опять эти глюки со страницами ! Они уже достали !!!
У меня есть раздел для просмотра только зарегистрированными пользователями.Там 3 новости.Так вот, раньше все новости сортировались от 1 страницы (она заполнялась полностью) до последней (она заполнялась тем что останется).Если я залогинился, то последняя страница вырастала на эти 3 новости.И всё было прекрасно!
Но недавно я поменял хостинг,и скачал заново "обновлённую" версию RC5.И начались глюки эти со страницами!!!
Это из-за того, что в новой версии новости выводятся иначе. Последняя страница заполнялась полностью, а на 1 страницу переносились "остатки"! И это породило ГЛЮКИ: Часть новостей теперь при залогинивании переезжает на "нулевую" страницу.Ну раньше же такого не было!!!
Сделайте что-нибудь!

P.S. Сейчас заметил, что если залогиниться на главной простым пользователем, а после зайти в админку, то всё отображается как надо... :o


P.S.S. При залогинивании админом криво отображается блок ввода комментария:

Loader
Так-с-с! Это опять я. :)
Кто нибудь знает, где подправить текст, который приходит при регистрации пользователя?Вот он какой:



Название сайта берётся из title , что не есть хорошо, кроме того значок "}" после имени явно лишний!

sanes
по поводу скобки ХЗ где-то наверняка в коде копать надо. Форматы писем настраиваются в модуле Аккаунт пользователя.
Loader
Цитата (sanes @ 2010-07-26, 19:22)
по поводу скобки ХЗ где-то наверняка в коде копать надо. Форматы писем настраиваются в модуле Аккаунт пользователя.


Нашёл, сенкс !!! :D
Даже скобка там же легко убирается !
kdv1978
Подскажите пару дней назад скачал RC5 и обновил имеющуюся у меня версию, в логах стали писаться ошибки такого типа -

Trying to get value from the unknown variable <code><b>Template -› qclass</b></code> Line: 133 in file /home/rknnru/public_html/classes/mainclass.php
URL: /account.html
Date: 2010-07-26 22:16:41
IP: 93.120.192.252

и


Notice: Undefined index: captcha_off Line: 43 in file /home/rknnru/public_html/classes/captcha/class_captcha.php
URL: /articles/уплотнительные-манжеты-и-ленты-для-монтажа-кровли.html
Date: 2010-07-26 22:11:06
IP: 91.192.149.231

плюс при попытке входа в аккаунт при наборе адреса www.site.ru/account.html появляется чистая страница с ошибкой

Произошла ошибка Trying to get value from the unknown variable Template -› qclass
Сохраняйте спокойствие: ошибка записана - админ придет, разберется.

В чём может быть баг? До загрузки последнего обновления такого небыло.
Loader
Alexander , ну где же Вы??
Глюки со страницами стали ещё больше!
У меня есть раздел "Эротика", там 20 новостей, он доступен только пользователям и администраторам.
Так вот, после залогинивания в этом разделе отображается только 10 новостей!! И всё!
В основном разделе news.html 20 последних новостей пропадает после залогинивания!
HELP! HELP ! :help:

Отловил этот глюк !!! который описан выше.
Он появляется когда на сайте уже находится пользователь, а ты заходишь после него и - обломись!



P.S. При залогивании на сайте админом потом невозможно выйти при нажатии "Выход"!Вообще нереально, пока куки не удалишь!
А если простым пользователем, то всё нормально !!!
Нашел такой баг. Добавляю на статическую страницу текст, использую в тексте "маркированный список", так вот то что находится в списке при сохранении удаляется.
sanes
Кажется были проблемы со списками. Попробуйте в bb редакторе прописать, как HTML

[dohtml]
<ul>
<li>Пункт 1</li>
<li>Пунтк 2</li>
</ul>
[/dohtml]
Цитата (sanes @ 2010-08-02, 14:08)
Кажется были проблемы со списками. Попробуйте в bb редакторе прописать, как HTML

[dohtml]
<ul>
<li>Пункт 1</li>
<li>Пунтк 2</li>
</ul>
[/dohtml]


sanes, как всегда, большое спасибо ;) Мне это не сильно важно. Просто нашел баг, решил отписать :)
p.s: список в таком виде работает
Alexander
Loader, я был в отпуске - отдыхал на берегу Черного моря. Имею право. Сейчас буду со всем разбираться, причем с глюками на форуме - в первую очередь.

Цитата (Loader @ 2021-07-29 00:14)
И некоторое количество новостей было добавлено без неё.В дальнейшем я эту галку поставил.

Завтра разберусь с этим. Обязательно. (Сегодня уже спать).

Цитата (Loader @ 2021-07-29 00:14)
Часть новостей теперь при залогинивании переезжает на "нулевую" страницу.Ну раньше же такого не было!!!
Сделайте что-нибудь!

Я Вам все исправлю. Только пожалуйста, помогите и Вы мне: давайте сразу ссылки на глючащие сайты. Спасибо. А еще лучше, давайте эти проблемы обсудим с Вами по мылу. Обещаю, что все будет работать.


kdv1978, каюсь. Случайно вкрался файл от разрабатываемой первой версии. Архив заменил, замените файл modules/account/user/index.php

Yurik82, буду благодарен, если скините на мыло адрес сайта с данными доступа для диагностики и исправления ошибки со списками на a@eleanor-cms.ru
Loader
Цитата (Alexander @ 2010-08-03, 0:45)
Loader
Я Вам все исправлю. Только пожалуйста, помогите и Вы мне: давайте сразу ссылки на глючащие сайты. Спасибо. А еще лучше, давайте эти проблемы обсудим с Вами по мылу. Обещаю, что все будет работать.


Так ведь в подписи сайт у меня! Мыло: pda-kino@ya.ru


В форме обратной связи не работают эти кнопки:

Loader
Так-с, все перечисленные выше баги устранены.
Есть такой вопрос:



При нажатии в новости на заголовок и на "Читать далее" ссылки принимают следующий вид:
pda-kino.net.ru/news/priklyu...va-titanov.html - при нажатии заголовка
pda-kino.net.ru/news/priklyu...tml#more</a> - при нажатии "Читать далее"



Так как убрать это "#more" , вроде и моря поблизости нет никакого... :rofl:

Maximkaboom
/modules/news/user/index.php
Loader
Цитата (Maximkaboom @ 2010-08-05, 16:59)
/modules/news/user/index.php


Ага...сделал
sanes
Loader, ты запоминай, а лучше записывай, что в коде делаешь. Пригодится, когда обновляться будешь
Loader
Цитата (sanes @ 2010-08-05, 18:54)
Loader, ты запоминай, а лучше записывай, что в коде делаешь. Пригодится, когда обновляться будешь


Там уже столько наделано, что всё и не вспомнишь! :blink:

В FAQ у всех в Интернет Эксплорере ошибка вылазит, или только у меня?

Loader
Alexander , а где подключается файл wz_tooltip.js?
Просто я его удалил, и надо ещё отключить где-то...
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.