CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Оптимизация превью в RC5
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Секреты и советы
Страницы: 1, 2
scanread
Loader, может конфликтирует с другим каким. Посмотри в мозилле на страницу через просмотр ошибок или в файрбаге.

У меня вот что показало:


Предупреждение: Несбалансированное дерево было написано с использованием document.write(), что привело к повторному парсингу данных из сети. Для получения более подробной информации прочтите https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing
Источник: http://pda-kino.net/page/test.html
Строка: 28


У меня показывает на локальном все чисто.
Loader
Цитата (scanread @ 2021-06-15 22:14)
Loader, может конфликтирует с другим каким. Посмотри в мозилле на страницу через просмотр ошибок или в файрбаге.

Я на локалке пробовал ещё на чистой системе - всё равно не работает.
Alexander
На простой странице работает? Т.е. удаляем все, оставляем только скрипт, добиваемся, чтобы он работал на чистой странице. Как только заработает - помещаем его на страницу системы. А дальше уже с глюками разобраться. Пробуйте.
scanread
В общем, как сделать так, чтобы когда добавляю картинку, текст что после нее выравнию по ширине, обтекал ее, а не шел внизу, под ней ? А то как-то не красиво так, в общем...

Мне это вкраткой новости надо, а в полной, там ниже будут идти картинки по центру... Как его примудрить так, чтобы одно другому не мешало?

АПДЕЙТ:

Не знаю, насколько верно, но сделал для этого свой ВВ-код, и ну все нафиг :) Главное, что работает )))
Alexander
Цитата (scanread @ 2021-06-15 22:14)
В общем, как сделать так, чтобы когда добавляю картинку, текст что после нее выравнию по ширине, обтекал ее, а не шел внизу, под ней ? А то как-то не красиво так, в общем...

style="float:left" - не?
scanread
Alexander, канает, но потом когда в новости добавляю еще картинки, и выравниваю их по центру, то нифига не канает, слева отображаются. Више же АПДЕЙТ написал, что создал свой ВВ-код, теперь быстро и без проблем картинки слева, а текст справа обтекает :)
scanread
В общем, нашел новую фичу, тоже на английском все было, ну пофиг, перевелось и установилось норм ;) Кому надо норм превью одной картинки или целой пачки картинок - милости прошу - ТЫЦ
Loader
Цитата (scanread @ 2021-06-15 22:14)
В общем, нашел новую фичу, тоже на английском все было, ну пофиг, перевелось и установилось норм Кому надо норм превью одной картинки или целой пачки картинок - милости прошу - ТЫЦ

Нормально, но слишком много жаба скриптов.
scanread
Цитата (Loader @ 2011-11-02, 10:28)
Нормально, но слишком много жаба скриптов.


Да они много не жрут то ) И грузит быром ) ИЕ 9 даже поддерживает норм ;)
scanread
И чего все молчат, что конфликтирует? :) От зараза, комменты и рейтинг не работает. Пришлось еще одну библиотеку стягивать. Тьфу тьфу тьфу, терь все норма, оттестировал только что. Вроде бы без приколов) Завтра выложу, наверное) И да, кстати, 1 файл на подключение только будет, как в LightBox 3.1 ;)
Loader
Цитата (Loader @ 2021-06-15 22:14)
Перепробовал всё. И на локалке и на сайте - не работает хоть тресни!


Короче я докопался до сути этой проблемы. Оказывается, с jQuery версии выше 1.2 галерея не работает.
Чтобы она заработала, нужно в файле thickbox.js найти
$('a[@rel='+imageGroup+']')
и заменить на
$('a[rel='+imageGroup+']')

Теперь всё работает! :crazy:
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.