CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Ошибка при установке
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Первые шаги
Привет всем!

Вот решил попробывать ваш движок, но сходу столкнулся с проблемой при установке.

Когда набираю в адресной строке www.mysite.com/install/

то получаю страницу с такой ошибкой:

Fatal error: Call to undefined function mb_internal_encoding() in /home/fruser/public_html/install/init.php on line 32

ЧМОДы расставил

На сервере стоит:

cPanel Version - 11.28.83
MySQL version - 5.0.91
PHP version - 5.2.8
Apache version - 2.0.63


в чём может быть проблема?

Любые другие движки устанавливаю без проблем...

Screatch
Очевидно что отсуствует модуль php_mbstring.

Дёргайте хостера.
Попросил поставить модуль о котором вы написали.

Вроде поставили "Mbstring extension has been enabled in your server now."

Но тепер уже другая ошибка появилась.....

Parse error: syntax error, unexpected $end in /home/fruser/public_html/classes/mainclass.php on line 797
Screatch
Выглядит как будто коряво залили.
termit
Залейте все файлы Тоттал Коммандером заново
velzavul
у меня бывали такие случаи в других цмс, самописных правда.
Скрипт сообщает о синтаксической ошибке в переменной $end в документе по указанному пути. 797 строка.ъ

Но могу и ошибаться, но обычно заглядывал по указанному адресу, малость правил код и все работало. (Не в этой цмс и ошибка похожая)
Тотал коммандером залил, не помогло...

Поробывал установить другой движок, установился без проблем...
Alexander
3ero, если parse error - однозначно глючит заливалка. То, что другой движок залился без проблем - не удивительно, ведь не все залитые файлы eleanor cms запоролись.
KeSSLeR
3ero, залей систему архивом через тотал командер
Всё, получилось!

Спасибо всем за быстрые ответы!
Ещё одна проблема при установке...



У меня ГД библеотека установлена, и работает!
Спросил у хостинга для точности.

в чём дело?
Alexander
3ero, наличие библиотек определяется доступностью функций. Очевидно, библиотека установлена как-то не полностью.
ка это так? ведь все остальные скрипты, в том числе галереи работают без проблем... может это скрипт мозги делает на ровном месте?
Попросил переустановить, но всё равно не пашет.....

Может самому что-то активировать? У меня VPS сервер, полный доступ через WHM
Alexander
Цитата (3ero @ 2021-06-19 11:31)
ка это так?

Функция imagefttext отпуствует.
Ее можно как нибудь активировать?
Alexander
Попинайте хостера или того, кто сервером занимается.
"попинал" хостера, теперь всё пашет = )

спасибо за поддержку
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.