CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » EleanorServ - Beta
Официальный форум Eleanor CMS » Проект Eleanor CMS » Наши новости
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11
Ребята, спасибо за этот серввер: в разы удобнее Денвера и XAMPP!
Однако при тестировании возникла проблема:
1. делаю локальный хост, создаю базу и начинаю ставить cms MaxSite CMS.
2. при установке выдает следущее:
Цитата
PHP Error was encountered

Severity: Warning

Message: require_once(install-common.php): failed to open stream: No such file or directory

Filename: core/Loader.php(679) : eval()'d code

Line Number: 49
Fatal error: require_once(): Failed opening required 'install-common.php' (include_path='.;D:\EleanorServ\bin\php\PEAR') in D:\EleanorServ\www\maxcms.loc\system\core\Loader.php(679) : eval()'d code on line 49

Вскрытие пациента показало, что в папке D:\EleanorServ\bin\php\ нет папки PEAR!
При попытке скопировать паку с Денвера и проверить пути в php.ini ничего не дало. А расширение для php PEAR используется во многих CMS.
Может посмотрите и подскажите, как настроить ручами сей досадный баг?
странно, только что испытал, ошибок не выдало, установка пошла.
Цитата
Filename: core/Loader.php(679) : eval()'d code

Это могло означать отсутствие поддержки php5.3. самим скриптом.
Zver
Не плохо бы его сделать кросс-платформенным.
Под Wine выдает критическую ошибку апача
Цитата (orkz @ 2011-09-11, 11:56)
странно, только что испытал, ошибок не выдало, установка пошла.

Это могло означать отсутствие поддержки php5.3. самим скриптом.


Странно, я лично проверил 3 версии MaxSite CMS. Ни одна не пошла. Могу скришоты выдать если нужно подтверждения моих слов.
Самое интресное, что на XAMPP 1.7.4 в версией PHP 5.3.5 все устанавливается влет.
Я не разбираюсь в программирвании PHP, но вот что говорит Великий ГУГЛ:
Цитата
PEAR (акроним от английских слов PHP Extension and Application Repository) — это библиотека классов PHP с открытым исходным кодом. В стандартную поставку PHP входит система управления классами PEAR, которая позволяет легко скачивать и обновлять их.

Вот как раз этого расширения и нет, получается!
Дык вопрос в том как самому его прикрутить или разработчики внесут его в сборку?

Извиняюсь если вопрос тупой, но как установить права 777 на файлы хоста? А то через фтп не хочет ставить... Подскажите пожалуйста.

Zver
Что пишет то, когда "не хочет ставить"?

Цитата (Zver @ 2011-09-13, 18:09)
Что пишет то, когда "не хочет ставить"?


"Не удается изменить атрибуты удаленных файлов".
Пользуюсь тоталом.
Screatch
Цитата
Не плохо бы его сделать кросс-платформенным.
Под Wine выдает критическую ошибку апача

Не удивительно. Под линукс пока собирать не планируем. Мне лично стандартных средств вполне хватает.
sudo apt-get install tasksel -> sudo tasksel -> выбираем LAMP пробелом и ENTER.
Без панельки правда.

ash, CHMOD надо ставить только под линукс серверами, в этом случае права не нужны.
Поясните на каком этапе у вас возникает ошибка.

Про PEAR себе пометил, будет.
Цитата (Screatch @ 2011-09-13, 20:25)
ash, CHMOD надо ставить только под линукс серверами, в этом случае права не нужны.
Поясните на каком этапе у вас возникает ошибка.

Дело в том, что после перезапуска EleanorServ не сохраняются таблицы в MySQL. Установил скрипт, но там написано прописать права 777. Думал, что из-за этого вылетает база. Похоже нет. <_<

колоссальная работа , качество отличное , заменил мне денвер , благодарю Вас ребята!
KDesign
Не все CMS поддерживает почему то
не интерпритирует php местами
Zver
Цитата (Screatch @ 2011-09-13, 20:25)
Не удивительно. Под линукс пока собирать не планируем. Мне лично стандартных средств вполне хватает.
sudo apt-get install tasksel -> sudo tasksel -> выбираем LAMP пробелом и ENTER.
Без панельки правда.

Я сейчас так и сижу apache2+php+mysql
не очень удобно) А с панелью раз-раз и все готово
Screatch
Цитата (ash @ 2011-09-13, 18:58)
Дело в том, что после перезапуска EleanorServ не сохраняются таблицы в MySQL. Установил скрипт, но там написано прописать права 777. Думал, что из-за этого вылетает база. Похоже нет. <_<


В личку или в аську мне напишите, разберёмся.

Цитата
Не все CMS поддерживает почему то
не интерпритирует php местами

Какие ошибки?
Maximkaboom
Screatch, замечал вот что по этому поводу. не поддерживает короткую запись, типа :

<?
echo'Hello world';
?>


Только так:

<?php
echo'Hello world';
?>
Screatch
Откройте php.ini и поменяйте там:

short_open_tag=Off на short_open_tag=On
Или в случае отсуствии этой записи, просто добавьте её.

Благодарю за замечание, поправим.
KDesign
спасибо!
вроде бы работет!
спасибо большое за сервер!

KDesign
при делегировании нескольких внешних доменов сервер выдает index of/
тоесть не видит дерикторию сайта
но почему то корректно работают некоторые из поддоменов(не все)
если оставить 1 домен то все в порядке
Ребята , я что-то никак не могу найти расширения OpenSSL , оно тут есть вообще ? :)
Нашёл расширение , оно было отключено по-умолчанию ... Включил его , но оно всё-равно не активно ... В php.ini его по-моему нет ... Что нужно сделать , чтобы активировать OpenSSL ?
KDesign
поддомены отказываются работаьть если ставить внешний IP!!
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.