CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Создаются не все таблицы
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Первые шаги
Zver
В общем решил поставить новую Эльку и уже на установке все запоролось
http://i30.fastpic.ru/big/2012/0129/6b/56f0a1cd6d12faea199f138c3bf7546b.png
Создаются не все таблицы бд, анивирус офф, стоит EleanorServ Beta
При этом установка завершается и даже говорится об успехе)) Естественно сайт не открывается и вылетают о ошибки
Цитата

Произошла ошибкаПри выполнении запроса произошла ошибка: (error #1364) Field 'ip_user' doesn't have a default valueАдрес ошибки: C:\EleanorServ\www\web-spell.el\core\core.php[1231] 



Добавлено через 4 минут, 33 секунд:

P/S Пробовал ставить 2 раза, все одно. Эти же самые таблицы не создаются
Zver
Что только не делал, все равно эти 8 таблиц не хотят устанавливаться, раз 10 наверное уже переустанавливал систему, 2 раза перекачивал архив и UTF-8 и windows-1251
Alexander
Zver, тут дело в том, что ваш MySQL как-то глючно настроен. Он почему-то реагирует на ошибки строгости. Ну что это за ошибка: "Field 'ip_user' doesn't have a default value"? Для varchar полей нужно указывать значения по-умолчанию? Бред какой-то. Пустая строка - вот значение по-умолчанию. Попинайте хостера.
Zver
Я же говорю сервер EleanorServ Beta, попробую скачать Denwer
Zver
Да, действительно, на Денвере все ок
Zver
В общем творятся какие-то непонятности, поставил Denwer и на EleanorServ заработало :sarcastic_hand:
sanes
Похоже у вас хостер дюже умный :) На 95% коммерческих шаредах Eleanor будет работать нормально.
Zver
Да сколько ж можно говорить то, у меня на локалеке стоит EleanorServer. Нет никакого хостинга! И да, проблема решилась сама собой, не понятно как, но решилась
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.