CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Обсуждение Eleanor CMS 0.9 PRE
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Первые шаги
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45
Alexander, у меня на сайте вот такое чудо творится. Сайт - svetlovodsk-workout.org.ua

Есть меню "Тренировки" + подменю "Соревнования" и "Еженедельные тренировки". Если я перехожу на какое либо подменю, оно исчезает, и его больше нет в выпадающем списке. Если потом нажимаю на оставшееся подменю, переходит на страницу подменю, но в выпадающем списке снова исчезает...и получается что меню остается без подменю....чтобы вернуть подменю нужно перейти на другие страницы.

Но! Эта проблема только в хроме....в мозиле все нормально работает.
qpPeW
Цитата (MelkoR @ 2012-05-13, 21:28)
Закомментировал, только так )) «502 Bad Gateway nginx/1.1.14» Админка работает нормально


Цитата (MelkoR @ 2012-05-13, 22:13)
Скинул доступ в ПМ

Добавлено через 7 минут, 21 секунд:

Хм.. Если открыть http://имя_сайта/новости.html то сайт работает, а если главную страницу http://имя_сайта/index.php «502 Bad Gateway»


решение это проблемы нашли ?
а то я что то не могу найти его в теме, если оно там описано...
буду благодарен если опишите !
Alexander
stas-klymenko, могли бы вы сделать скрин? А то я не врубаюсь немного...
qpPeW, показывайте сайт. Посмотрим, что можно сделать.
qpPeW
Цитата (Alexander @ 2012-06-08, 21:34)
stas-klymenko, могли бы вы сделать скрин? А то я не врубаюсь немного...
qpPeW, показывайте сайт. Посмотрим, что можно сделать.

отправил в ЛС
Alexander, я вроде бы понял проблему.

Смотри. Для примера, есть сайт, с верхним горизонтальным меню "Главная|Новости|Страница1|Страница2"
Я создаю статическую страницу "номер 1" Открыв ее, все нормально.
Теперь, мне не нужна "Страница2" и я ее удаляю из меню. Остается "Главная|Новости|Страница1"
Вроде бы все нормально бы, но если теперь перейти на статическую страницу "номер1" то "Страница2" все равно показывается, хотя я ее уже и удалил отовсюду.
То есть, если нажать на главную, на новости, на "Страница1", то все будет в порядке....а если перейти на статическую страницу "номер1" (например через ссылку в блоке) то в меню снова отображается "Страница2"....хотя эта страница нигде не выставлена.

По ходу, каким-то образом статические страницы запоминают отображение меню и потом его восстанавливают если на них переходить. Чтобы все было нормально, нужно просто пересоздать статическую страницу "номер1" и все уже нормально будет.

В хроме вообще очень тупит меню вместе с статическими страницами, в мозилке все более-менее нормально, хотя иногда тоже тупит меню.

Надеюсь понятно объяснил....скринами сложно показать.
DeD
stas-klymenko, а вы не пробовали после всех этих операций почистить кеш, как системы так и браузера?
Да, когда в мозиле все отображало правильно, а в хроме продолжало тупить, я кэш почистил, увидел свою ошибку. Забыл написать что решил проблему. Но спасибо, что написали. :rolleyes:
Alexander
stas-klymenko, это кэш браузера. FF его может неправильно удалять. Можете добавить мусора к ссылке (...page1.html?trash) и убедиться, что все в порядке.
Alexander, спасибо за совет. Пока что вроде бы не вижу багов. Только форума жду :)
LuxCore
Цитата (termit @ 2019-09-16 10:13)
Перезалейте тотал командером, все остальные "заливалки" делают свое дело как-то криво.
Спасибо. Всё нормально теперь работает.
LuxCore
Если в Личном блокноте или Общем что-то написать и всё, что написал, удалить, то нет слова "нет":
qpPeW
Только что пробовал ставить другой релиз, ошибка та же...
Разберитесь пожалуйста в чем проблема !
qpPeW
Может хоть кто то подскажет как ее решить ?
Прошло 3 дня, а в танке как было глухо так и осталось...
SmUp
В управлении блоками добавил блок (текстовой), перетаскиваю, отображается две штуки. На локалке (VertrigoServ) так на и на сайте отображается две штуки. при удалении одного на локалке удаляются оба. На сайте так-же, но при удалении из админки одного все равно показывет две штуки!? В логах чисто.
Djadka
Баг поттверждаю так же если тянуть из левого списка в какой то раздел для блоков то блоки дублируются. Как на локалке так и хостинге использовал Лису
Flynt
qpPeW, пишите Александру на мыло.
Ребят, в каком файле можно скрыть от индексации этот блок?
Все новости Категории Теги Поиск Добавить новость
Djadka
модули, новости, шаблоны, классы и там вроде usernews.php и там топ меню
Flynt
Djadka, точнее, я в php - баранка. :)
Djadka
templates\Uniel или Ваш шаблон. Ищем Menu.php в нём 21 строчка перед тегом <ul ставим <noindex>, или как там его звать, и после </ul> тоже </noindex>
Вроде так
qpPeW
Цитата (MelkoR @ 2012-05-13, 21:28)
Закомментировал, только так )) «502 Bad Gateway nginx/1.1.14» Админка работает нормально


Цитата (MelkoR @ 2012-05-13, 22:13)
Скинул доступ в ПМ

Добавлено через 7 минут, 21 секунд:

Хм.. Если открыть http://имя_сайта/новости.html то сайт работает, а если главную страницу http://имя_сайта/index.php «502 Bad Gateway»


Решение проблемы должно быть следующим: откройте файл core/core.php найдите строку

if(method_exists($this->l,$n))

и удалите ее.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.