CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Отказ от поддержки PHP 5.2.x
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Разработка системы
Alexander
Все чаще посещает мысль отказаться уже от поддержки PHP 5.2.x и перейти на PHP 5.3.x а лучше на PHP 5.4 (чтобы трейты юзать). Тогда можно будет еще более улучшить код, подогнав его под большинство рекомендаций принципов SOLID. + появится возможность вынести большинство кода в Eleanor Framework для того, чтобы и другие могли писать свои CMSки ;)
Djadka
до 5.4 надо ждать хотя бы месяцев 6-8. А то нормальные хостинг провайдеры ставят к себе новую версию пхп только с нормальным обкатом.(писал уже =) )
DeD
Alexander, использование новых возможностей php и подгонка под рекомендации это конечно хорошо, но все же я думаю не стоит торопиться. Решать тебе все же. Сначала лучше выпустить финал, а уж затем думать об этом.
Alexander
DeD, и снова все тупо ждут финал... мда.
Djadka, где-то к этому времени и появится версия, так что думаю, если сейчас ориентироваться на 5.4 то как только 5.4 будет стоять везде - так сразу и версия новая выйдет :)
Loader
Цитата (Alexander @ 2020-10-19 20:15)
DeD, и снова все тупо ждут финал... мда.

Почему? Я его совсем не жду! Мне и так хорошо. :sarcastic_hand:
LuxCore
А мне греет душу само существование системы Eleanor. Я и так вижу, что проект не стоит на месте, да и сам Александр говорит, в какую сторону собирается развивать своё детище.
Djadka
Вот почему то вот как то вот кажеться что пока не стоит. Я бы полностью сейчас первёл бы её на 5.3 и сделал бы отдельную ветку под 5.4. Потому что надо добиться универсализма.
Alexander
Djadka, думаю, месяцев через 5 везде будет стоять 5.4 . До этого первая версия точно не выйдет - так что по-моему уже сейчас есть смысл переходить на 5.4...
termit
Немного оффтопа и юмора.
Решил поработать с одним фреймворком (F3).
Сделал небольшой проэкт, залил на хост. - Не работает. (на хосту php5.2 нужен php5.3+).
Меняю на php 5.3 - не работает, но ощибка уже другая
Меняю на php 5.4 - имею internal server error (даже на скрипте в котором и есть только что <?php phpinfo();?>)
Пишу в тех поддержку

Я
Цитата
Здраствуйте.
Насколько я понял php5.4 работает в режиме cgi. Можно ли както его использовать как модуль апача.
Не работают даже елементарные скрипты. например phpinfo http://*/phpinfo.php


Ответ мне понравился)

Вася П.
Цитата
Добрый день. На данный момент php5.4 - не стабильная версия, рекомендуем использовать php5.3


Я
Цитата
Извиняюсь, но не настолько ведь не стабильная что не может сделать даже <?php phpinfo();?>
Вопрос немного не о том.

Андрей Г.
Цитата
может. только нужно было отключить magic_quotes_gpc. Просто как модуль апача использовать нельзя


Djadka
Цитата (Alexander @ 2012-06-23, 20:56)
Djadka, думаю, месяцев через 5 везде будет стоять 5.4 . До этого первая версия точно не выйдет - так что по-моему уже сейчас есть смысл переходить на 5.4...


Да только мой хостер тупит на эту тему.
Phoenix84
Alexander, толковой документации к php 5.4 сейчас практически не найти. Да и 5.3 будет существовать столько же сколько и php 5.2
Alexander
Цитата (Phoenix84 @ 2020-10-19 20:15)
Alexander, толковой документации к php 5.4 сейчас практически не найти.

А какую документацию вы ждете? :) Был обзор новинок, уже понятно как ими пользоваться. Чего не хватает?

PHP 5.4 вполне стабильно, если суди по http://php.net/downloads.php
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.