CMS Eleanor - Поиск
Полная версия этой страницы: Официальный форум Eleanor CMS » Установка на Openserver
Официальный форум Eleanor CMS » Поддержка пользователей системы Eleanor CMS » Первые шаги
Добрый день.

Пытаюсь установить eleanor_cms_0.9 на Openserver и при обращении к http://site1.ru/install/install.php выскакивает ошибка:

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in E:\OpenServer\domains\site1.ru\core\core.php on line 1265

строка 1265 представляет собой: if(!$over=$L::GetUserValue($go) or !isset($over['method'][$p],$over['value'][$p]) or $over['method'][$p]=='inherit') вот в таком сочетании:

public static function GetPermission($p,$L=false,$t=false,$go='groups_overload')
    {
        if(!$L)
            $L=self::$Login;
        if(!$over=$L::GetUserValue($go) or !isset($over['method'][$p],$over['value'][$p]) or $over['method'][$p]=='inherit')
            return self::Permissions(self::GetUserGroups($L),$p,$t);
        $res=($add=$over['method'][$p]=='replace') ? array($over['value'][$p]) : self::Permissions(self::GetUserGroups($L),$p,$t);
        if(!$add)
            $res[]=$over['value'][$p];
        return$res;
    }

Подскажите кого где добавить/удалить/закоментировать чтоб это всё заработало.
wormen
какая версия сервера?
версия продукта 4.7.6.0
wormen
работаю на этом же сервере той же версии, никаких проблем.....
попробуйте скачать отсюда последнюю версию CMS
не хотит работать всё равно ((((( я уже и ютф8 попробывал поставить - ни в какую (((

может это из-за системы чего? стоит Win 7 x32 - може в ней дело?
Hoodlum
Цитата (4erepaha @ 2013-01-28, 15:30)
не хотит работать всё равно ((((( я уже и ютф8 попробывал поставить - ни в какую (((

может это из-за системы чего? стоит Win 7 x32 - може в ней дело?

Нет дело и не win 7, у меня стоит версия 4.6.0 на Win 7 x32 и все отлично работает. Дело может быть у вас в том что не настроен домен, я смотрю установка происходит site1.ru, попробуй домен обычный localhost?
сё. вопрос снят. черепашка немного медленная, потому не получалось )))

проблема была в версии PHP. я посмотрел что на сервере есть 3 штуки и решил что по умолчанию стоит последняя ))) а оказалось - первая.
Alexander
4erepaha, все правильно :) Eleanor CMS 0.9 требует PHP не ниже 5.3 версии.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.